Name '_wrapreduction' is not defined

#1

I was trying to run my code on Python. But the error show:

runfile(‘C:/Users/Grace/Downloads/dive_deep_simple_pose.py’, wdir=‘C:/Users/Grace/Downloads’)
Traceback (most recent call last):

File “”, line 1, in
runfile(‘C:/Users/Grace/Downloads/dive_deep_simple_pose.py’, wdir=‘C:/Users/Grace/Downloads’)

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\spyder_kernels\customize\spydercustomize.py”, line 827, in runfile
execfile(filename, namespace)

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\spyder_kernels\customize\spydercustomize.py”, line 110, in execfile
exec(compile(f.read(), filename, ‘exec’), namespace)

File “C:/Users/Grace/Downloads/dive_deep_simple_pose.py”, line 14, in
import mxnet as mx

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet_init_.py”, line 28, in
from . import contrib

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\contrib_init_.py”, line 31, in
from . import onnx

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\contrib\onnx_init_.py”, line 19, in
from .onnx2mx.import_model import import_model, get_model_metadata

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\contrib\onnx\onnx2mx_init_.py”, line 20, in
from . import import_model

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\contrib\onnx\onnx2mx\import_model.py”, line 22, in
from .import_onnx import GraphProto

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\contrib\onnx\onnx2mx\import_onnx.py”, line 25, in
from ._import_helper import _convert_map as convert_map

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\contrib\onnx\onnx2mx_import_helper.py”, line 21, in
from ._op_translations import identity, random_uniform, random_normal

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\contrib\onnx\onnx2mx_op_translations.py”, line 22, in
from . import _translation_utils as translation_utils

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\contrib\onnx\onnx2mx_translation_utils.py”, line 23, in
from … import module

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\module_init_.py”, line 22, in
from .base_module import BaseModule

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\module\base_module.py”, line 32, in
from …model import BatchEndParam

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\mxnet\model.py”, line 46, in
from sklearn.base import BaseEstimator

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\sklearn_init_.py”, line 64, in
from .base import clone

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\sklearn\base.py”, line 14, in
from .utils.fixes import signature

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\sklearn\utils_init_.py”, line 16, in
from .fixes import _Sequence as Sequence

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\sklearn\utils\fixes.py”, line 51, in
np.divide(.4, 1, casting=“unsafe”, dtype=np.float64))

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\numpy\core\numeric.py”, line 2423, in allclose

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\numpy\core\numeric.py”, line 2334, in isclose
if all(xfin) and all(yfin):

File “C:\Users\Grace\AppData\Local\Programs\Python\Python37\lib\site-packages\numpy\core\fromnumeric.py”, line 2245, in all
in the result as dimensions with size one. With this option,

NameError: name ‘_wrapreduction’ is not defined


Can anyone help me, I have no idea what’s going on

#2

It seems like there is an issue with an MXNet installation - NumPy version doesn’t match to the required one. How do you install MXNet? Can you try uninstall it and install it again using pip install mxnet?