Install MxNet with Cuda 9.1 + cuDNN 7.0.5 in Ubuntu 16.04 LTS


#1

There is a simple way to install MxNet with Cuda 9.1 + cuDNN 7.0.5 in Ubuntu 16.04 LTS?

Currently, it is only possible to install with Cuda 9.0 -> “pip install mxnet-cu90==1.0.0”


#2

There’s no CUDA 9.1 specific version released on PyPi yet:

https://pypi.python.org/pypi/mxnet-cu91

Recommend building from source.


#3

Thank you.

I have tried but unfortunately I that get an error at the end of the process , i.e., when I install the MXNet Python binding:

(AIBILI_MXNET) lgmendes@lgmendes-Laptop:~/incubator-mxnet/python$ pip install -e .
Obtaining file:///home/lgmendes/incubator-mxnet/python
_ Complete output from command python setup.py egg_info:_
_ Traceback (most recent call last):_
_ File “”, line 1, in _
_ File “/home/lgmendes/incubator-mxnet/python/setup.py”, line 46, in _
_ LIB_PATH = libinfo’find_lib_path’_
_ File “/home/lgmendes/incubator-mxnet/python/mxnet/libinfo.py”, line 59, in find_lib_path_
_ ‘List of candidates:\n’ + str(’\n’.join(dll_path)))_
_ RuntimeError: Cannot find the files._
_ List of candidates:_
_ /home/lgmendes/incubator-mxnet/python/mxnet/libmxnet.so_
_ /home/lgmendes/incubator-mxnet/python/mxnet/…/…/lib/libmxnet.so_
_ /home/lgmendes/incubator-mxnet/python/mxnet/…/…/build/libmxnet.so_
_ /usr/local/cuda-9.1/lib64/libmxnet.so_
_ …/…/…/libmxnet.so_
_ _
_ ----------------------------------------_
Command “python setup.py egg_info” failed with error code 1 in /home/lgmendes/incubator-mxnet/python/


#4

Can you check and see if libmxnet.so is in /home/lgmendes/incubator-mxnet/lib/ ?


#5

@szha can we provide cu91? the default cuda version is now 9.1.


#6

Sure, I’m on it now.


#7

I’m wondering whether it’s done soon. I plan to use coda 9.1 with mxnet.


#8

Hi Szha, do I understand that you are deploying a cuda 9.1 mxnet version? Im on 9.1 and i cant revert down to 9.0 simply as i have other dependencies,
thanks
xk