Installing on OS X High Sierra (10.13)


#1

The present installer of MXnet does not support installation to OS X High Sierra. Does anyone have a solution on how to work around this limitation? Thanks.


#2

What error do you run into?


#3
pip install mxnet-mkl -U --pre

#4

ERROR: macOS version 10.13 NOT supported.


#5

Maybe you can compile mxnet refer Linux style.


#6

In the installation script install-mxnet-osx-python.sh, in function main() at the very bottom of the file, comment out the call for “chk_mac_vers”