Installation

how did you do that ?..could you please elaborate

This appears broken for me. I’m on Ubuntu 18.04 with Python 3.6.5 using 4.5.4. I’m trying to follow the instructions, but when I test the installation by running ‘import d2l’ in the notebook I get:

ImportError: cannot import name ‘linreg’

update: it looks like the following commit broke the d2l import: https://github.com/d2l-ai/d2l-en/commit/241260f6a015e9d16c25984159c77bab64e22c4d

Checkout out the previous commit worked for me.

If you want any information regarding the installation then have a visit on kaspersky antivirus error 1922 where you can learn it on details.

would be nice if the d2l downloaded code was labeled with the corresponding chapters.
For example, 2.1.1: getting started is located in

d2l-en/chapter_crashcourse/ndarray.ipynb

If it was in

d2l-en/2.crashcourse/1.ndarray.ipynb

it would be a lot easier to find.
Or atleast have the notebooks have the same name as the chapter: 2.1 Data manipulation -> data_manipulation.ipynb instead of ndarray.ipynb

Very neat project !
Soon all hard science textbook will be in this format.
Just one question for now:
is there an index available for the downloaded version ?
In “mxnet-the-straight-dope-master” there was a README.md file
that could be converted to ipynb and worked as en Index.

For MacOSX, the command for “Installing Running Environment” should be

$ pip install https://apache-mxnet.s3-accelerate.amazonaws.com/dist/python/numpy/latest/mxnet_mkl-1.5.0-cp37-cp37m-macosx_10_11_x86_64.whl

When trying to install the d2l dependency on google colab , I am getting a prompt toolkit error . The prompt toolkit error is because colab jupyter kernel uses an older version while the d2l uses the newer version. How do I solve this?

Hi I’m new to this book and am excited to get into learning. I have followed the steps for installation and am able to get jupyter notebook to launch properly however in the first part of lesson two when I try to run the code “from mxnet import mx” I get an OS error stating that I have a missing module, but I have already pip installed mxnet. Can someone please let me know what is going on it is extremely frustrating.

Could anyone help with this mismatch error? I got it to work previously with @ThomasDelteil 's advice on April 10th, but following the advice again now has not resolved the issue.

The exact error I get, upon trying to import mxnet as mx in the notebook, is the following:

Following the same advice, which is to symlink cuda and make sure cuda is in the dynamic path library:

After doing this I still receive the same issue. Mxnet-cu100 is installed via pip

Quick note: I see the MiniConda/Conda Envs part of the installation is no longer there? Is pip install preferred now?

Thanks for any help, I really appreciate it.

Hi, I have Spyder (Python 3.7.4) open and am running the first code lines. “jupyter notebook” always seems to give me error: SyntaxError: invalid syntax. Anyone knows why?

I am getting “cannot import name ‘np’ from ‘mxnet’”

Python Version: 3.7
MXNet Version: mxnet-cu100 1.5.1.post0

1 Like

Hi. When I tried to download the code from the link https://d2l.ai/d2l-en-0.7.0.zip. But it seems to be that file was damaged. I downloaded it in win 10. Does anyone knows why?

Hi. I’m getting the following error even after installing everything that was mentioned in the tutorial.

ImportError** : cannot import name ‘np’ from ‘mxnet’

I use Windows.

Hi @YashwanthAllakky, thanks for the feedback. Here are several quick inspections:

  1. Did you activate the environment? For example,

conda activate d2l

or

source activate d2l

  1. Have you tried the following:

pip install -U --pre mxnet

  1. If the above still doesn’t work, please uninstall mxnet and reinstall it.

Hi everyone, I need help with installation of d2l environment in cuda mode. I have Win 7 PC and followed all installation instructions to the letter (so no deviations, as far as I know). The problem is that I have python consistently crashing at least in some notebooks (e.g., rnn-gluon.ipynb) with an exception code 40000015, complaining about ucrtbase.dll
Not sure if it is related, but just before crashing I also always recieve a warning about some potential incompatibility of cudnn.dll (see a snapshot).

I’ve tried different sub-versions of cudnn10.1 (including 7.5.0, 7.6.0) with no difference. My GPU card is RXT 2060 with Cuda 10.1.243.
Also I can run notebooks with no issues in CPU mode though (i.e. with mxnet==1.6.0b20190926, instead of mxnet-cu101==1.6.0b20190926, of course uninstalling the other mxnet first).
Any suggestions or ideas would be very welcome.
Many thanks!

P.S. Overall this interactive book is a great idea, so really looking forward to going through all of it at least in CPU mode, if not GPU.

using ubuntu 18.04 and successfully running conda env. Installed python, pip, mxnet, d2l, and jupyter notebook as per instructions. when I run a block of code in the notebook I get error:

“The kernel appears to have died. It will restart automatically.”

running python in command line gives

import numpy
import mxnet as mx
Illegal instruction (core dumped)

…so i believe my issue is with the mxnet download? Any direction would be great! Have enjoyed reading the book thus far.

have anyone installed d2l and mxnet in google colab?
when i do !pip install d2l mxnet, i see this following warning after installation; So i reset my runtime and then it never re-connects.


And when i connect to a runtime again, and i would then have to start with pip installation command again and the issue repeats. how do i solve this?

Hi @jdpeiffer6, last time I have this issue I reinstall conda and jupyter. Maybe this link can help: https://github.com/jupyter/docker-stacks/issues/811

Let me know whether it works?!

I think it would be useful to also add instructions to starting this up in SageMaker studio. Would make for a 2-click setup almost.

I followed the steps in the installation section on my windows PC. When I run any of the chapters in Jupyter notebook, the links to other sections of the book do not work. For example, the main index notebook looks like this:

Any tips on how to fix this would be appreciated. Thanks!