How to use mxnet gpu verion in kaggle kernel?


#1

I’m tring to install mxnet-cu92 in kaggle kernels, but I got an error Could not install packages due to an EnvironmentError: [Errno 30] Read-only file system: '/opt/conda/bin/f2py'.

Anyone successfully use mxnet gpu verion in kaggle? any advices?

thanks in advance.


#2

When I turn GPU on in Kaggle kernel, it doesn’t allow me to install custom packages. How did you install mxnet-cu92?


#3

I also encountered the same problem. I first trun off the gpu in settings panel, then type in !pip install mxnet-cu92 in the jupyter notebook code cell or directly use the Packages option within this panel.

When I restart my program, the GPU is turned on. Now I got a new error: GPU is not enabled, however, the GPU was exactly enabled.

I noticed that the running Docker changed when I want to use the installed mxnet-cu92.


#4

Did you try a !pip list |grep mxnet to make sure when you enable GPU you are indeed running mxnet-cu92?