GPU 9.0 MKL speed slowed down after reboot


#1

I installed the cu9.0 mkl via below command. The first time for me to open the jupyter notebook to run a notebook to classify EMNIST data, the speed was twice of it under cu8.0. However, when I restart the system, that speed up disappeared.
command:
pip install mxnet-cu90mkl

My system is ubuntu 16.04, cuda 9.0 and cudnn7.0 were all installed. The HW was an ASUS G751 laptop(980M 4G, 32G ram, 512SSD).

Many thanks!


#2

Could you try the latest version of MXNet and let us know your findings?

https://pypi.python.org/pypi/mxnet/

Since you are using a laptop (most probably no GPUs), there may be many processes running in the background which may have an effect on performance – difficult to pinpoint. Can you let us know if the behavior is consistent for multiple times – how many times did you try? Also, please let us know the exact performance numbers.

You could try various performance-related tips here:
https://mxnet.incubator.apache.org/how_to/perf.html
especially using MXNet profiler. If you share the profiler output here then the performance bottlenecks can be pinpointed.


#3

Many thanks, bhavinthaker.

I tried again with the mxnet_cu90mkl-1.0.0.post1-py2.py3-none-manylinux1_x86_64.whl
Still could not get the super speed I observed. Current speed is almost same as it was in cuda8.0

The GPU of my laptop is a Nvidia GTX 980M. I tried my desktop, which has a 1060, but I still could not find that super speed.


#4

Another issue was I build from the source failed from 0.12. It worked in 0.11 on the same computer, and the only difference was installed cuda 9.0. I reported my finding in another post.