Gluon-cv 0.4.0 error that didn't occur in 0.3.0

#1

I updated to Gluon-cv 0.4.0 and received this error doing the Instance Segmentation tutorial using MASK-RCNN MXNetError: [12:14:12] src/ndarray/ndarray.cc:752: Check failed: !IsMKLDNNData() We can’t generate TBlob for MKLDNN data. Please use Reorder2Default() to generate a new NDArray. Using mxnet version 1.4.0

#2

Which MXNet version are you using?

#3

Just tried it on another machine with mxnet 1.4.0 and gluon-cv 0.30 and received same the only thing different about this version of 1.4.0 is that it was build with intel mkl 2019 release 3 all my previous builds have been with mkl 2018 release 4 . I did a rebuild with mkl 2018 and it made no difference still receive the same error.

#4

When you installed MXNet did you use MKL version? By default, MXNet comes without MKL support and you need to install a version which has mkl suffix. For example, for CUDA 9.0 and MKL supported version of MXNet you need to type:

pip install mxnet-cu90mkl

Similar for CUDA 9.1, 9.2, 10.0 - replace the number in the command.
Try to reinstall mxnet and let me know if it helped.

#5

I have always built from source since I started using MXNet version 0.7 never used pip install, using Intel’s MKL, jemalloc and nccl. Never had any issues until now, and that is the only one I have a problem with finished the rest of gluoncv tutorial without any issues and no problems with gluonnlp. This was the first time I used mkl 2019 but went back and did a build with 2017 release 4 and the problem persisted. I start with the same settings you list for your builds then add the ones for nccl and use_cpp_package . I had gone through that tutorial before without any issues not sure why my builds are having trouble now and only with that one.

#6

Did a pip install and it worked fine. Uninstalled it and reinstalled mine will trouble shoot on my own sorry for the confusion in hindsight I should have noted that I build from source just never occurred to me since I have never used a pip install for mxnet.

#7

No problem at all. Feel free to post your findings - it might benefit other people as well!